Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Outage in Zurich
Jun 07, 05:20 UTC
|
Resolved after 8 minutes
|
Affected: Zurich
We are currently experiencing some issues with servers in Zurich. Please find the details below.
Incident's timeline
Resolved
Jun 07, 05:28 UTC
VPN43 is online.
Jun 07, 05:28 UTC
VPN43 went offline.
Jun 07, 05:20 UTC
Last update:
2024-12-22 16:35:02