Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Outage in Stockholm
Jul 02, 18:05 UTC
|
Resolved after 7 minutes
|
Affected: Stockholm
We are currently experiencing some issues with servers in Stockholm. Please find the details below.
Incident's timeline
Resolved
Jul 02, 18:13 UTC
VPN15 is online.
Jul 02, 18:13 UTC
VPN15 went offline.
Jul 02, 18:05 UTC
Last update:
2024-12-22 10:25:02