Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Outage in Tokyo
Jul 30, 16:38 UTC
|
Resolved after 8 minutes
|
Affected: Tokyo
We are currently experiencing some issues with servers in Tokyo. Please find the details below.
Incident's timeline
Resolved
Jul 30, 16:46 UTC
VPN89 is online.
Jul 30, 16:46 UTC
VPN89 went offline.
Jul 30, 16:38 UTC
Last update:
2024-12-22 10:35:02