Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Outage in Zurich
Sep 20, 19:30 UTC
|
Resolved after 11 hours
|
Affected: Zurich — VPN43
We are currently experiencing some issues with servers in Zurich. Please find the details below.
Incident's timeline
VPN43 went offline.
Apr 16, 04:54 UTC
Resolved
Sep 20, 19:36 UTC
VPN43 is online.
Sep 20, 19:36 UTC
VPN43 went offline.
Sep 20, 19:30 UTC
Last update:
2024-12-22 05:05:02