Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Outage in London
Oct 12, 06:45 UTC
|
Resolved after 15 hours
|
Affected: London — VPN68
We are currently experiencing some issues with servers in London. Please find the details below.
Incident's timeline
VPN68 went offline.
Jun 21, 21:35 UTC
Resolved
Oct 12, 22:25 UTC
VPN68 is online.
Oct 12, 22:25 UTC
VPN68 went offline.
Oct 12, 22:18 UTC
VPN68 is online.
Oct 12, 13:07 UTC
VPN68 went offline.
Oct 12, 12:09 UTC
VPN68 is online.
Oct 12, 07:11 UTC
VPN68 went offline.
Oct 12, 06:45 UTC
Last update:
2024-12-21 17:50:02