Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Outage in Paris
Oct 12, 21:35 UTC
|
Resolved after 9 minutes
|
Affected: Paris — VPN69
We are currently experiencing some issues with servers in Paris. Please find the details below.
Incident's timeline
VPN69 went offline.
Oct 10, 22:09 UTC
Resolved
Oct 12, 21:44 UTC
VPN69 is online.
Oct 12, 21:44 UTC
VPN69 went offline.
Oct 12, 21:35 UTC
Last update:
2025-04-21 10:40:02