Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Ongoing DDoS attack
Jun 17, 10:35 UTC
|
Resolved after 20 hours
|
Affected: Frankfurt, Erfurt, Tokyo, Zurich, Copenhagen
We have an ongoing DDoS attack against our servers
Incident's timeline
Resolved
Jun 17, 12:25 UTC
The mitigation methods have been implemented in the affected data centers
Last update:
2024-12-23 18:45:02