Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Issues with website
Jul 13, 12:16 UTC
|
Resolved after 5 hours
|
Affected: WEB01
We are currently experiencing issues with our website due to an influx of requests. We're investigating the cause.
Incident's timeline
Resolved
Jul 13, 13:21 UTC
The request flood has been mitigated.
Last update:
2024-12-23 19:15:01