Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 week ago
Past incidents
Amsterdam Maintenance (Rack migration)
Jul 01, 08:00 UTC
|
Resolved after 7 hours
|
Affected: Amsterdam
Incident's timeline
Maintenance complete
Jul 01, 15:53 UTC
Maintenance completed.
In progress
Jul 01, 14:47 UTC
Started
Jul 01, 08:00 UTC
Maintenance period has started.
Last update:
2025-07-10 16:35:03