Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Service interruption in Frankfurt
Oct 06, 16:36 UTC
|
Resolved after 1 hour
|
Affected: Frankfurt
An unexpected outage has occurred in Frankfurt. We're investigating.
Incident's timeline
Resolved
Oct 06, 18:09 UTC
The outage has been resolved by M247.
Started
Oct 06, 16:36 UTC
Outage started
Last update:
2024-12-23 19:30:02