Planned maintenance: Frankfurt

Apr 22, 04:00 UTC | Scheduled for 4 hours | Affects: Frankfurt

Planned maintenance: Stockholm

Apr 22, 06:00 UTC | Scheduled for 6 hours | Affects: Stockholm

Streaming issues in the US

Nov 09, 19:00 UTC | Resolved after 1 day | Affected: Atlanta, Chicago, Dallas, Los Angeles, Miami, New York

We're currently having issues accessing streaming services in the US. We're investigating the issue.

Incident's timeline
Resolved Nov 11, 08:04 UTC
Streaming is now working again
Issues started Nov 09, 19:00 UTC
Issue started
Last update: 2024-04-19 12:40:04