Status
Current status
Upcoming maintenance
Past incidents
All systems operational
Last incident
1 month ago
Past incidents
Global issue due to Level3
Aug 30, 11:04 UTC
|
Resolved after 17 hours
|
Affected: Stockholm
There is an issue network wise through entire Europe due to Level3. We're following the progress, but there is not much we can do right now.
Incident's timeline
Resolved
Aug 30, 16:51 UTC
The issue has been resolved.
Last update:
2024-11-24 15:40:02